OFFROADSUBARUS.COM

Go Back   OFFROADSUBARUS.COM > General Forums > New Member Introductions

Notices

Reply
Thread Tools Display Modes
  #1  
Unread 18th November 2018, 07:54 AM
Mudfreek Mudfreek is offline
New Member
 
Join Date: Nov 2018
Location: New hampshire
Year: 1999
Model: Legacy outback
Transmission: Auto
Posts: 2
Mudfreek is on a distinguished road
Default Hello Iím new

Hello Iím new to Subaru ownership I curently own a 1999 Subaru Legacy outback Iíve owned it for a week
Iíve been through one snowstorm and so far I love this car
I do have minor issues Speedo doesnít work all the time needs an o2 sensor
Quarter panel is crinkled and 4 very small rust spots so Iíd say not bad for a grand
Reply With Quote
  #2  
Unread 18th November 2018, 01:11 PM
jf1sf5's Avatar
jf1sf5 jf1sf5 is offline
Forum Member
 
Join Date: Aug 2012
Location: Geneva, Switzerland
Posts: 1,655
jf1sf5 is on a distinguished road
Default

Welcome to the Subaru family !
__________________
Subversive...
Reply With Quote
  #3  
Unread 18th November 2018, 07:57 PM
ABFoz ABFoz is offline
Forum Member
 
Join Date: Mar 2018
Location: Auckland, New Zealand
Year: 2005
Model: Forester XS
Transmission: 4EAT
Posts: 98
ABFoz is on a distinguished road
Default

Welcome to the forum @Mudfreek. There is a chance your Vehicle Speed Sensor is broken. A brand new genuine one is not expensive.


Happy wheeling!
Reply With Quote
  #4  
Unread 18th November 2018, 09:52 PM
Mudfreek Mudfreek is offline
New Member
 
Join Date: Nov 2018
Location: New hampshire
Year: 1999
Model: Legacy outback
Transmission: Auto
Posts: 2
Mudfreek is on a distinguished road
Default

Thanks for the reply yes I've already looked into the speed sensor s being the issue
But if I push the trip reset the speedometer works
I've searched the net and looks like i might only have to solder a jumper wire in certain spot
Reply With Quote
  #5  
Unread 18th November 2018, 11:17 PM
Kevin's Avatar
Kevin Kevin is offline
Administrator
 
Join Date: Jul 2008
Location: Sydney, Oz
Year: MY'03
Model: Forester
Transmission: A/T
Posts: 4,579
Kevin is on a distinguished road
Default

G'day & Welcome aboard @Mudfreek
__________________
MY'03 Foz AT XS with centre lock-up
MY'10 Triton AT GLX-R 2.5 DiD
www.subaruclub.com.au
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -3. The time now is 03:25 PM.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.