OFFROADSUBARUS.COM

Go Back   OFFROADSUBARUS.COM > Technical Forums > General Troubleshooting and Technical Help

Notices

Reply
Thread Tools Display Modes
  #1  
Unread 30th June 2018, 08:24 PM
Ben Up North's Avatar
Ben Up North Ben Up North is offline
can only hope to improve
 
Join Date: Sep 2017
Location: FNQ
Year: 2004 | 1992
Model: SG Forester X MY05 | 92 SVX
Transmission: 5MT D/R | 4EAT
Posts: 802
Ben Up North is on a distinguished road
Default OBD/OBDII Questions

So I bought this cheapy OBDII bluetooth dongle.

Using Torque Lite it works fine on the newer model cars we have (Hyundai & Toyota both around 3 years or so old - company cars, who cares!) but can't find the ECU on my MYO5.

So what I'm trying to figure out, is is it the dongle, the software, or is there something amiss in my wiring?

Is there any cheap way of finding out? Being the noob that I am when it comes to these fancy new motors (last motor I did any sort of real work on was a '76 beetle in the early 80's) I know nothing about this stuff.

Do mechanics normally just plug into the standard OBDII connection for diagnostics?


Any help greatly appreciated.
Have a great day all!
Ben
__________________
SLO White Foz, Quicksilver SVX!

Last edited by Ben Up North; 30th June 2018 at 10:00 PM.
Reply With Quote
  #2  
Unread 30th June 2018, 08:36 PM
Ratbag's Avatar
Ratbag Ratbag is offline
Administrator
 
Join Date: Jan 2012
Location: Bayside, Melbourne, Vic
Year: MY06, MY10
Model: Forester SG & SH
Transmission: 5MT/DR & 4EAT Sports
Posts: 6,226
Ratbag is on a distinguished road
Default

Ben, IIRC all the Foresters since the beginning of series I SG are OBDII compliant. So your dongle should work with your 2005 model.

I have a cheapie dongle that works fine in my 2006 model. Also works in our 2010 SH.
Reply With Quote
  #3  
Unread 30th June 2018, 09:10 PM
Ben Up North's Avatar
Ben Up North Ben Up North is offline
can only hope to improve
 
Join Date: Sep 2017
Location: FNQ
Year: 2004 | 1992
Model: SG Forester X MY05 | 92 SVX
Transmission: 5MT D/R | 4EAT
Posts: 802
Ben Up North is on a distinguished road
Default

Well, I've just learnt cheaper ODBII connecters didn't work with Subarus back in 2012.
I guess maybe things haven't changed.


A recommendation on an inexpensive ODBII connector that is known to work with Subarus would be greatly appreciated.
__________________
SLO White Foz, Quicksilver SVX!
Reply With Quote
  #4  
Unread 30th June 2018, 09:15 PM
Ben Up North's Avatar
Ben Up North Ben Up North is offline
can only hope to improve
 
Join Date: Sep 2017
Location: FNQ
Year: 2004 | 1992
Model: SG Forester X MY05 | 92 SVX
Transmission: 5MT D/R | 4EAT
Posts: 802
Ben Up North is on a distinguished road
Default

Quote:
Originally Posted by Ratbag View Post
I have a cheapie dongle that works fine in my 2006 model. Also works in our 2010 SH.

What did you get and where from?
Cheers,
Ben
__________________
SLO White Foz, Quicksilver SVX!
Reply With Quote
  #5  
Unread 30th June 2018, 09:15 PM
Ben Up North's Avatar
Ben Up North Ben Up North is offline
can only hope to improve
 
Join Date: Sep 2017
Location: FNQ
Year: 2004 | 1992
Model: SG Forester X MY05 | 92 SVX
Transmission: 5MT D/R | 4EAT
Posts: 802
Ben Up North is on a distinguished road
Default

Anyone have any idea what protocol is used?
__________________
SLO White Foz, Quicksilver SVX!
Reply With Quote
  #6  
Unread 30th June 2018, 09:26 PM
Ratbag's Avatar
Ratbag Ratbag is offline
Administrator
 
Join Date: Jan 2012
Location: Bayside, Melbourne, Vic
Year: MY06, MY10
Model: Forester SG & SH
Transmission: 5MT/DR & 4EAT Sports
Posts: 6,226
Ratbag is on a distinguished road
Default

Quote:
Originally Posted by Ben Up North View Post
What did you get and where from?
Cheers,
Ben
Ben, I bought it about 4-6 years ago. It's a bog standard, Chinese dongle that cost about $10 ...

Have no idea what "brand" it was, or who I bought it from.

It also works on a friend's Suzuki Grand Vitara.

I also use Torque Lite with it.

Apparently, it's always been a bit of a gamble whether these work or not.

IIRC OBDII uses a standard RS232 comms protocol.
Reply With Quote
  #7  
Unread 30th June 2018, 09:45 PM
subyroo's Avatar
subyroo subyroo is offline
Senior Member
 
Join Date: Jul 2008
Location: Sunshine Coast - Australia
Posts: 356
subyroo is on a distinguished road
Default

Quote:
Originally Posted by Ben Up North View Post
Anyone have any idea what protocol is used?

Don't trust my memory 100% Ben but I seem to remember my 2003 XS Forester using the 9141 protocol or ISO 9141-2.


I had an UltraGauge fitted to my Forester, it never logged anything just allowed me to monitor whatever sensors I wanted.

I mainly bought it to monitor the water temp as the Subaru Temp gauge is not reliable IMO, once it hits the red which can be pretty quick, it is can be too late to save the engine.
__________________
Peter
2016 Honda CR-V
Reply With Quote
  #8  
Unread 30th June 2018, 10:01 PM
Ben Up North's Avatar
Ben Up North Ben Up North is offline
can only hope to improve
 
Join Date: Sep 2017
Location: FNQ
Year: 2004 | 1992
Model: SG Forester X MY05 | 92 SVX
Transmission: 5MT D/R | 4EAT
Posts: 802
Ben Up North is on a distinguished road
Default

@Kevin can you please fix the title, I've got a real problem with getting OBD right!
__________________
SLO White Foz, Quicksilver SVX!
Reply With Quote
  #9  
Unread 30th June 2018, 10:03 PM
Ben Up North's Avatar
Ben Up North Ben Up North is offline
can only hope to improve
 
Join Date: Sep 2017
Location: FNQ
Year: 2004 | 1992
Model: SG Forester X MY05 | 92 SVX
Transmission: 5MT D/R | 4EAT
Posts: 802
Ben Up North is on a distinguished road
Default

Quote:
Originally Posted by subyroo View Post
I mainly bought it to monitor the water temp as the Subaru Temp gauge is not reliable IMO, once it hits the red which can be pretty quick, it is can be too late to save the engine.

That's the main reason for me, We hit the red on temp a couple of times last year. Engine's still running but, so hopefully it's OK.
__________________
SLO White Foz, Quicksilver SVX!
Reply With Quote
  #10  
Unread 30th June 2018, 10:43 PM
Kevin's Avatar
Kevin Kevin is offline
Administrator
 
Join Date: Jul 2008
Location: Sydney, Oz
Year: MY'03
Model: Forester
Transmission: A/T
Posts: 4,526
Kevin is on a distinguished road
Default

Quote:
Originally Posted by Ben Up North View Post
@Kevin can you please fix the title, I've got a real problem with getting OBD right!

Done
__________________
MY'03 Foz AT XS with centre lock-up
MY'10 Triton AT GLX-R 2.5 DiD
www.subaruclub.com.au
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -3. The time now is 02:27 AM.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.