PDA

View Full Version : Air Conditioning Compressor


spinners
3rd November 2009, 07:57 AM
Well well. It has been quite a while since I was last here. Not the best of years for me and my family, but that is another storey.

Every week I turn the AC on for a few minutes just to keep it all moving etc.

Did so this morning and as the compressor kicked in, I began to get a squeal for the engine bay, momentarily though. Turned it off and left it alone.

This afternoon, did the same thing, but whilst driving along, I'd get the same squeal but also a noticeable drain on the engine revs.

So:


Is the bearing in the compressor on the way out?
If so, has anyone else experienced a similar thing?
How much may I be up for?
Any AC specialists one may recommend in the Sydney area?
If not the compressor, what else may it be AC related?



Your assistance with this query would be greatly appreciated.

aware
3rd November 2009, 08:23 AM
I had the same thing on my MY05. But it was a result of a service at Denlo Subaru on James Ruse Drive as they didn't install the belt properly so it did that everytime it was turned on. It was fixed with a new belt installed.
Perhaps look at the belt for the AC.

Kevin
3rd November 2009, 09:33 PM
Maybe since the squeal you've become more sensitive to the power drain by the A/C? First I would check the belt tension and try some belt dry lube and see what happens.

Beigewagon
4th November 2009, 04:59 PM
As Kevin said, check the belt tension first, if it is too loose it will squeal. My L-Series did the same thing on the long weekend, and I dint have the tools with me to fix it until I got home.:raspberry:

Beigewagon.

spinners
6th November 2009, 05:27 PM
Cheers guys, I'll take a look this weekend.