OFFROADSUBARUS.com

Go Back   OFFROADSUBARUS.com > Technical Forums > Car Care

Notices

Reply
 
Thread Tools Display Modes
  #21  
Old 18th July 2009, 02:44 AM
SubaCool's Avatar
SubaCool SubaCool is offline
Senior Member
 
Join Date: May 2009
Location: Brighton, Colorado
Posts: 418
SubaCool is on a distinguished road
Default

Thanks, but it could look a lot better if I've actually put any effort into it. But then again, I'd just get it dirty again
__________________
KUBO
07 Outback 2.5i, 00 2.5RS GM6 (AX&RX special)
Reply With Quote
  #22  
Old 12th August 2009, 06:00 AM
fandizzle's Avatar
fandizzle fandizzle is offline
Senior Member
 
Join Date: Sep 2008
Location: brissy
Model: XT
Posts: 221
fandizzle is on a distinguished road
Default

lol I always make sure, after a trip out I clean every bit of the engine bay (or what I can get to) to prevent any problems that may occur in the future!
__________________
Too many mods to list!
Reply With Quote
  #23  
Old 16th September 2009, 03:06 AM
yarney's Avatar
yarney yarney is offline
Senior Member
 
Join Date: Dec 2008
Location: Logan Qld
Posts: 385
yarney is on a distinguished road
Default

When i hose my engine bay i hose everything except the alternator every thing else gets wet i have never had a water problem before (touch wood)

Jan
__________________
Subies will go anywhere
Reply With Quote
  #24  
Old 4th November 2010, 11:05 AM
taza's Avatar
taza taza is offline
Senior Member
 
Join Date: Oct 2010
Location: Perth, Western Australia
Posts: 3,837
taza is on a distinguished road
Default

Quote:
Originally Posted by yarney View Post
When i hose my engine bay i hose everything except the alternator every thing else gets wet i have never had a water problem before (touch wood)

Jan
Same here.
I first hosed my engine with a medium spray then spayed it with engine degreaser, left it for 5mins then hosed it all off. Then left to dry for an hour with the bonnet open. Its extremely clean now

But if you are obsessive about it then get a can of WD-40 and a rag and go for your life
__________________
Current vehicle - 84 MY Wagon EJ22 4 Speed
Reply With Quote
  #25  
Old 4th November 2010, 11:56 AM
4rester 4rester is offline
Junior Member
 
Join Date: Jun 2010
Location: Manly Brisbane Queensland
Posts: 13
4rester is on a distinguished road
Default

Too easy spray a WD40 or CRC in plugs (anti penetrating fluild) and use a degreaser. Leave degreaser on for 15- 20 minutes spray with high preasure. MAKE SURE ENGINE IS COLD. Repeat until engine is clean. Advoid high preasure to alternater,aircond kompressor and spark plugs directly. Best way to clean spark plug leads is to replace them!!!!!
Reply With Quote
  #26  
Old 4th November 2010, 11:58 AM
4rester 4rester is offline
Junior Member
 
Join Date: Jun 2010
Location: Manly Brisbane Queensland
Posts: 13
4rester is on a distinguished road
Default

PS find out where your ECU is and avoid that as well
Reply With Quote
  #27  
Old 13th November 2010, 06:25 AM
AlpineRaven AlpineRaven is offline
Senior Member
 
Join Date: Jul 2010
Location: Melbourne Victoria
Posts: 164
AlpineRaven is on a distinguished road
Default

heh... mine is just as bad, i have dried up mud all over my engine and i gotta clean it up as i have a slow oil leak somewhere and need to find out..

Normally I use de-greaser on a cold engine and high pressure clean it up, I havent done that for 4 yrs now.
Cheers
AP
__________________
1996 Liberty GX with 1.59:1 low range 5MT AWD
Reply With Quote
  #28  
Old 1st May 2011, 08:54 AM
Levy Levy is offline
Junior Member
 
Join Date: Apr 2011
Location: Townsville, Qld
Posts: 6
Levy is on a distinguished road
Default

Well I just gave my new girl a clean (not the engine, just the body) and now have a 'check engine' light. Too late tonight to muck about getting the error code. Maybe I got some water on some part of the engine I shouldn't have when I filled the windscreen washer? Took her for a lap about the block, and am not sure if it's me but she doesn't seem to be running as smoothly as before. I've a '99 Outback auto, any suggestions?
Reply With Quote
  #29  
Old 1st May 2011, 08:47 PM
Levy Levy is offline
Junior Member
 
Join Date: Apr 2011
Location: Townsville, Qld
Posts: 6
Levy is on a distinguished road
Default

Alright, everyone calm down, crisis averted.. no idea what the issue was but the light's not on this morn. Situation normal.. phew.
Reply With Quote
  #30  
Old 1st May 2011, 09:44 PM
garrettG's Avatar
garrettG garrettG is offline
Senior Member
 
Join Date: Jan 2011
Location: southern california, 92694
Posts: 283
garrettG is on a distinguished road
Default

Oh man I need to clean mine... I'm scared that I'm gonna find rust under all the dirt.
__________________
2001 SF. D/R 1.59 low
Keep the forums mellow!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -3. The time now is 05:19 PM.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.