OFFROADSUBARUS.COM

Go Back   OFFROADSUBARUS.COM > Technical Forums > Interior and Exterior

Notices

Reply
Thread Tools Display Modes
  #1  
Unread 2nd March 2016, 05:27 AM
Pecky's Avatar
Pecky Pecky is offline
Forum Member
 
Join Date: Aug 2008
Location: Perth - Western Australia
Posts: 66
Pecky is on a distinguished road
Default Dirty windscreen

I was having trouble getting the windscreen clean on my 2010 Forester. I tried changing the windscreen wipers and all sorts of windscreen washer additives but I always had a haze/smear across the windscreen after using the windscreen washer. It ended up that there was a build up of algae/muck in the windscreen washer reservoir which I found by putting the hose in there and letting it run till overflowing. This must have stirred it up the sediment in the reservoir and eventually the water ran clear and the problem was fixed.

Cheers
__________________
Pecky
MY10 Diesel Forester + MY06 Auto Forester
Reply With Quote
  #2  
Unread 2nd March 2016, 06:02 AM
Ratbag's Avatar
Ratbag Ratbag is offline
Administrator
 
Join Date: Jan 2012
Location: Bayside, Melbourne, Vic
Year: MY06, MY10
Model: Forester SG & SH
Transmission: 5MT/DR & 4EAT Sports
Posts: 6,226
Ratbag is on a distinguished road
Default

We had that same problem with the Camry once. Fixed it the same way. Sort of white congealed gunk IIRC.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -3. The time now is 12:33 PM.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.