OFFROADSUBARUS.COM

Go Back   OFFROADSUBARUS.COM > Technical Forums > Transmission and Driveline

Notices

Reply
Thread Tools Display Modes
  #1  
Unread 5th February 2018, 03:07 PM
RabbidRabbit RabbidRabbit is offline
Forum Member
 
Join Date: Mar 2017
Location: U.S.A
Year: 1997
Model: Legacy
Transmission: Auto
Posts: 12
RabbidRabbit is on a distinguished road
Default Auto trans computer

I'm having an issue and need some advice about CELs. I pertty much run on a CEL for the transmission, P1720.1722? I am about to come up on testing and usually can get it to pass. I was running an evap cel but I thought I got it fixed. I put the reader on my car and pulled 22 codes. I can't remember them all but here is a list of what I can remember, evap, trans( PRND something, vss, shift, something about gearing), Knock sensor. What the heck is going on with my car? I have sanded all the grounds in the engine bay and even added a 4g from the trans to body. Car is a 97 Legacy sedan auto. I really need help if I can't get it right then I will have to scrap it and I really don't want to.

I have tried to figure the P1722 code for a few years and haven't had any luck figuring it out. All I have is a generic OBDII scanner.

I have a ECU and TCM from a 98 EJ25 should I swap just to see what happens?
Reply With Quote
  #2  
Unread 5th February 2018, 07:38 PM
NachaLuva's Avatar
NachaLuva NachaLuva is offline
Senior Member / Product Developer
Contributing Member
 
Join Date: Oct 2011
Location: SE Melbourne
Posts: 5,527
NachaLuva is on a distinguished road
Default

The ECU also has the immobiliser I believe, so if you swap it you'll also need the key. You could try swapping the TCU but it may not be faulty. 22 codes is a lot but many of them will overlap. Ie, 3 or 4 codes caused by the one fault. Try it to see what happens.

Also try cleaning the contacts in the connectors, they may be dirty or rusted.

You will also probably need to replace some of the sensors, esp the knock sensor & O2 sensor. A 97 is pretty old & many parts need regular maintenance
__________________
SUBIELIFTOZ, QUALITY LIFT KITS FOR SUBARUS
1" & 2" lift kits; custom lift kits; all models
Reply With Quote
  #3  
Unread 5th February 2018, 08:10 PM
Ratbag's Avatar
Ratbag Ratbag is offline
Administrator
 
Join Date: Jan 2012
Location: Bayside, Melbourne, Vic
Year: MY06, MY10
Model: Forester SG & SH
Transmission: 5MT/DR & 4EAT Sports
Posts: 6,230
Ratbag is on a distinguished road
Default

Agree with NL. However, I would recommend taking it to a good workshop that has a mechanic who understands cars ... Get them to diagnose your car's faults with their workshop analyser.

Complex/combined issues that you are apparently having require both the proper equipment and a competent diagnostician.
Reply With Quote
  #4  
Unread 5th February 2018, 08:33 PM
RabbidRabbit RabbidRabbit is offline
Forum Member
 
Join Date: Mar 2017
Location: U.S.A
Year: 1997
Model: Legacy
Transmission: Auto
Posts: 12
RabbidRabbit is on a distinguished road
Default

I have the wire harness from the 98. I plan on putting it in a Beetle one day.
Reply With Quote
  #5  
Unread 5th February 2018, 08:54 PM
RabbidRabbit RabbidRabbit is offline
Forum Member
 
Join Date: Mar 2017
Location: U.S.A
Year: 1997
Model: Legacy
Transmission: Auto
Posts: 12
RabbidRabbit is on a distinguished road
Default

I did find the EGR tube broken but it never threw a EGR code.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -3. The time now is 05:31 PM.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.